Počítačové školicí středisko
Školení
Konzultace

Dynamické seznamy

Dost často se ve firemní praxi vyskytují různé výpočty v Excelu v datové oblasti, která má pokaždé jiný počet řádků. Výpočty, ale také grafy, ev. kontingenční tabulky někdy připraveny tak, že pracují s pevným rozsahem dat. Rozsah dat se nemusí měnit každou minutu, stačí když se mění denně a už má obsluha problém. Musí adresy ve vzorci změnit a někdy bohužel nastávají také případy, že obsluha změnu rozsahu dat ani nezjistí...

Typickým a často se vyskytujícím případem je průběžný roční seznam, který se v průběhu roku neustále zvětšuje a v kterém se něco počítá. Obvykle se to řeší tak, že se výpočet připraví na odhadovaný roční rozsah seznamu a přidá se dostatečně velká rezerva. Ale ani to někdy nestačí, nehledě na to, že v určitých případech ani toto řešení není vhodné (např. když pod seznam potřebujete zapsat nějaká pomocná data).

Ideální řešení je použít tzv. dynamické seznamy. Microsoft tuto záležitost nazval Tables, v českých verzích jde o příkaz Vložit-Tabulka. Jenže název tohoto příkazu je velmi matoucí, mnozí ho považují za vytvoření nového sešitu nebo za vytvoření nějaké vložené tabulky v sešitu. Lépe je používat termín „dynamická tabulka“ nebo „dynamický seznam“. Jestliže výpočty vycházejí z dynamického seznamu, je zaručeno, že vždy budou pracovat s aktuálním rozsahem dat, ať již kratším, nebo delším. Rozsah dat ve vzorci se prostě sám bude aktualizovat.

Jak vytvořit dynamický seznam

Vyplněnou oblast dat (samozřejmě ve tvaru seznamu, souvisle vyplněnou, se záhlavími) označte a klikněte na Vložit-Tabulka. Takto převedete starý seznam na dynamický seznam. Označená oblast se graficky zformátuje, ale důležité je zejména to, že pokud postavíte kurzor dovnitř dynamického seznamu, na mezi kartami nástrojů se objevuje nová karta Návrh.

karta Návrh

Kliknete-li mimo dynamický seznam, karta zmizí.

Adresace v dynamickém seznamu

Při adresaci buněk v dynamickém seznamu je možno používat běžné adresy typu C2, ale mnohem častěji se využívají méně obvyklé adresy typu =Tabulka1[@Název] Chcete-li sečíst sloupce, můžete použít výraz např. =SUMA(A2:A50), ale také výraz =SUMA(Tabulka1[Název]). Atd.

Mezi hlavní přednosti dynamického seznamu patří:

1. Výpočty, grafy, kontingenční tabulky v něm vždy pracují s aktuálním rozsahem dat.

2. Záhlaví seznamu nikdy neodroluje mimo obrazovku. Jestliže je kurzor umístěn v seznamu a rolujeme, záhlaví se ukotví v řádku, kde byla původně označení sloupců.

3. Výpočtový sloupec (viz Návrh-Řádek souhrnů) dokáže snadno realizovat výpočty ve sloupci, aniž bychom museli znát příslušné výpočetní funkce.

4. Přidaná data se automaticky zahrnou do seznamu, podobně při odebrání dat.

Dynamický seznam má však i další výhody: má automaticky zapnuté filtrační šipky, automaticky se pojmenují přidané sloupce, je možné mu snadno měnit grafickou úpravu, hledat a odebírat duplicitní údaje apod.


Chcete o této problematice vědět více? Kontaktujte nás..

Únor 2019
 


© Počítačová škola Altix, s.r.o., nám. T. G. Masaryka 588, 760 01 Zlín, tel. +420 601 211 980, e-mail: info@altix.cz